php5.3에서 php5.4로 업그레이드 후 에러 문제...

쎄엠   
   조회 3893  

http://www.jesus91.net (429)

오랜 말에 불쑥 와서 질문을 드린다는 것이 죄송합니다만...
그누보드4 구버젼을 사용하고 있는 사용자입니다.
그런데 서버를 php5.3에서 php5.4로 업그레이드 한 것 같습니다.
그후에 그누보드로 된 홈페이지가 페탈에러나면서 열리지 않습니다.
홈페이지가 여러개인데 공통점이 최신게시글과 관련되어 있다는 것입니다.
대표적으로 한 싸이트만 링크해 보겠습니다.

*에러 표시 : Fatal error: Call to undefined function random_latest() in /website/jesus91/www.jesus91.net/index.php on line 15


*에러 내용 :
      <?= random_latest("yugi_banner", mainbanner, 1, 20)//MAIN BANNER?>

*에러주소. http://www.jesus91.net

질문.
php5.4는 변수가 까다롭다는 글을 보았습니다.
변수 때문에 최근게시글을 불러오지 못한다면 그누에 그런 글이 많이 올라올텐데....
그누보드, 네이버, 구글등 사방 검색해 보았지만 그런 내용이 없더라구요.
불당님이 변수 선언을 해 주어야 한다는 글을 보고 아래와 같은 내용을 처음에 넣어봐도 마찬가지입니다.
$g4['path'] = "..";
이와 같은 에러를 어떻게 해야 하는지 좀 가르켜 주십시요.
부탁드립니다.
수고하십시요....

업그레이드의 모든 것 MET
빠른수리, 예산절감, 자격보유, 1년보증 업그레이드 수리는 물론 구매까지 한번에!
주식회사 포유컴퓨터
가격비교1등 전부품공짜업 특별사은품 최대5년보장 당일발송 안심포장
유아한복 티몬
유아한복, 합리적인 가격, 특가 SALE 알뜰구매 찬스! 초저가, 빠른배송!
파워링크 AD   클릭초이스등록
불당 2014-12
해당 오류는 php와 무관한 것이고
php 5.4는 여러가지 이유로 그누보드에서 쓰기 어렵습니다.
그누보드 사용시 php를 5.3 이상으로 올리면 안됩니다.

 Call to undefined function random_latest() ...
말 그대로 해당 함수가 어디에도 없다는 것 입니다.
해당 함수를 찾아서 넣으면 되는거에요.
쎄엠 2014-12
아이고 불당님 말씀 감사합니다.
그런데 지금까지 잘 사용하였거든요.
당연히 index.php, 해당 최근게시글 스킨 그대로 있구요.
초보라서 조금 구체적으로 알려 주십시요...
감사합니다....
불당 2014-12
소스를 받아서 하나씩 점검해보세요.
그리고 php를 설정하면서 경로에서 빠졌을 수도 있구요.
이부분은 더 도움드릴 수 없는 부분입니다.
설명할 방법이 없거든요.
시간을 두고 찬찬히 하시거나 의뢰를 하시거나 하셔야 할거에요.

저는 의뢰는 안받으니, sir이나 phpschool에서 의뢰하심 될거구요.
쎄엠 2014-12
불당님 답변감사합니다.
건강하십시요...


제목Page 1/17
03-20   206   자미르
2015-09   2072   김당구
2015-09   2816   김당구
2015-01   3414   필승불패
2015-01   3529   할레이
2015-01   3166   필승불패
2014-12   3426   테스터
2014-12   3894   쎄엠
2014-12   2808   필승불패
2014-03   4341  
2014-02   6   진아얌
2014-01   4750  
2014-01   4566  
2013-12   4251  
2013-12   5230  
2013-12   4885  
2013-11   6336  
2013-11   5794   김당구
2013-11   5379   김당구
2013-11   5550   김당구